xref: /6.0.3/tlm/deps/manifest.cmake (revision b277d99e)
1#
2# Keep the list sorted alphabetically, and the platforms alphabetically.
3# The syntax is:
4#
5# DECLARE_DEP (name VERSION version-revision PLATFORMS platform1 platform2)
6#
7# This manifest contains entries for SUPPORTED platforms. These are
8# platforms on which Couchbase builds and delivers Server binaries
9# to customers.
10#
11# The list of supported platforms may change between releases, but
12# you may use the cmake macro CB_GET_SUPPORTED_PLATFORM to
13# check if this is a supported platform.
14#
15DECLARE_DEP (breakpad VERSION 20160926-cb1 PLATFORMS debian9 ubuntu16.04 windows_msvc2015)
16# breakpad 20160926-cb2 rebuilt using GCC 7.2.0.
17DECLARE_DEP (breakpad VERSION 20160926-cb2 PLATFORMS centos6 centos7 debian8 suse11.2 suse12.2 ubuntu14.04)
18DECLARE_DEP (boost VERSION 1.62.0-cb3 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
19DECLARE_DEP (curl VERSION 7.60.0-cb1 PLATFORMS centos6 centos7 debian7 debian8 debian9 suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
20DECLARE_DEP (erlang VERSION R16B03-1-couchbase-cb11 PLATFORMS macosx)
21DECLARE_DEP (erlang VERSION R16B03-1-couchbase-cb9 PLATFORMS centos6 centos7 debian7 debian8 debian9 suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
22DECLARE_DEP (flatbuffers VERSION 1.4.0-cb1 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
23DECLARE_DEP (flex VERSION 2.5.4a-cb1 PLATFORMS windows_msvc2015)
24DECLARE_DEP (flex VERSION 2.6.4-cb4 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04)
25DECLARE_DEP (icu4c VERSION 59.1-cb1 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
26DECLARE_DEP (jemalloc VERSION 4.1.0-cb2 PLATFORMS windows_msvc2015)
27DECLARE_DEP (jemalloc VERSION 4.5.0.1-cb1 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04)
28DECLARE_DEP (json VERSION 1.1.0-cb1 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
29DECLARE_DEP (libevent VERSION 2.1.8-cb4 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
30DECLARE_DEP (libuv VERSION 1.13.1-cb4 PLATFORMS centos6 centos7 debian7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
31DECLARE_DEP (lz4 VERSION 1.8.0-cb2 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04)
32DECLARE_DEP (maven VERSION 3.5.2-cb5 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
33DECLARE_DEP (numactl VERSION 2.0.11-cb1 PLATFORMS centos6 centos7 debian7 debian8 debian9 suse11.2 suse12.2 ubuntu14.04 ubuntu16.04)
34DECLARE_DEP (openjdk-rt VERSION 1.8.0.171-cb1 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
35DECLARE_DEP (openssl VERSION 1.0.2k-cb2 PLATFORMS windows_msvc2015)
36DECLARE_DEP (openssl VERSION 1.0.2k-cb3 PLATFORMS macosx)
37DECLARE_DEP (python-snappy VERSION c97d633 PLATFORMS windows_msvc2015)
38DECLARE_DEP (python-snappy VERSION c97d633-cb1 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04)
39# RocksDB 5.8.0-cb3 was an aborted version linked to Snappy 1.1.6
40# RocksDB 5.8.0-cb4 is rebuilt with GCC 7.2.0 on older platforms
41DECLARE_DEP (rocksdb VERSION 5.8.0-cb2 PLATFORMS debian7 debian9 macosx ubuntu16.04)
42DECLARE_DEP (rocksdb VERSION 5.8.0-cb4 PLATFORMS centos6 centos7 debian8 suse11.2 suse12.2 ubuntu14.04)
43DECLARE_DEP (snappy VERSION 1.1.1 PLATFORMS windows_msvc2015)
44DECLARE_DEP (snappy VERSION 1.1.1-cb2 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04)
45DECLARE_DEP (v8 VERSION 5.9-cb3 PLATFORMS centos7 debian8 macosx suse12.2 ubuntu14.04 ubuntu16.04)
46DECLARE_DEP (v8 VERSION 5.9-cb4 PLATFORMS centos6 suse11.2)
47DECLARE_DEP (v8 VERSION 5.9-cb5 PLATFORMS debian9)
48DECLARE_DEP (v8 VERSION 5.9-cb6 PLATFORMS windows_msvc2015)
49DECLARE_DEP (zlib VERSION 1.2.11-cb3 PLATFORMS centos6 centos7 debian8 debian9 macosx suse11.2 suse12.2 ubuntu14.04 ubuntu16.04 windows_msvc2015)
50